Tuesday, 29 October 2013

The Nikon D800 has serious AF accuracy problems if the AF assist light of the SB-900 is enabled

In a discussion on a large forum about camera gear somebody mentioned that there might be a problem with the D800 AF accuracy if the camera uses the SB-900 flash and the AF assist light of the flash is enabled and turns on for the image. The person who brought this up mentioned also that  it can have something to do with the colour temperature of the light, since the in-camera, white LED does not produce the same results and the AF works accurately with it. Initially I dismissed this as farfetched because I had hard time to believe that the accuracy of AF can have anything to do with the red AF assist LEDs, other than the fact that the LEDs allow the camera to focus at lower light level than it would be possible without. Never the less, I wanted to test before completely dismissing this as a myth.

Sadly, I have to admit that I was wrong, it is not a myth and it is definitely true that the D800 has serious AF accuracy problems when the SB-900 AF assist light is enabled, the problem is definitely confirmed and very easy to repeat. Though, it is not the colour of the light which is the problem, since even if the LEDs are totally covered the accuracy of the AF is still very bad, the camera consistently back focuses, i.e. the actual focus is after the focus area.

I have not noticed this problem before since I am not using the flash too often, but not so long ago I was out shooting a local event and came home with a bunch of badly focused images, which I thought was my own fault. I had enough usable images from that event, so I gave not much thought about the high number of out of focus images then, but now I know that the problem was the flash AF assist light, not a user error. I realize now that every image which needed the red AF assist light was out of focus and useless.

This is an extremely serious problem for every professional photographer, since the famous event photographer camera Number 1, the Nikon D800, has a very serious flaw regarding the auto focus because especially during events, the AF assist light is very often used. My otherwise perfectly well functioning camera definitely behaves strange with the AF assist light on, and the problem is apparently not just with my camera and my flash, but so far every other D800 user I have been in contact with, and not just the SB-900 flash but also the SB-700 has this problem.

Test setup

Camera set to single centre AF area in AF-S mode.
Focus priority is set to ON.
Camera in M mode, 1/200 second shutter speed and lens wide open, ISO800.
For the sample images here, I used the 24-120/4GVR and the 50/1.4G lenses
but tested also with the 105/2.8GVR macro.
The flash was on top of the camera, bounced from the roof.
The ambient light in the room was set to fairly low level, so that the camera could focus even without the AF assist if the AF assist light is turned off in the flash, but uses the AF assist light if it is set to on. This way the tests are consistent, ambient light does not have to be changed to allow focus without AF assist light, so it should result in identical images both with and without the AF assist light.

A3 size test chart was used with a target area which gives focus confirmation in 100% of the cases under the low ambient light. The actual AF target was the center of the test chart, the circular pattern, which is a "good" AF target for the center AF spot. Distance was about two meters to the target with the 120mm, less with the 50mm lens. I was standing to the right from the target to be able to verify consistency in AF accuracy error.

About 50 images with, and 50 without AF assist light were taken with each lens, manually offsetting the focus between each image to make sure that it is necessary for the camera to focus each time the shutter is released.
The camera was previously tested by me with all the lenses and was considered accurate. The camera and lenses are all one year or older, used frequently and working perfectly well. No problems whatsoever with lenses, flash or the camera. The flash was used also on a D300s before, without any problems and even the AF assist light gave consistently good AF accuracy with that camera. The images under Results are cropped images of the AF area and the size is 100%. 


Every time the SB-900 AF assist light is ON the camera back focuses. The image to the left is taken with the 24-120/G lens at f/4. This is consistent, easily repeatable, and the amount of back focus is always the same.

Also tested covering the AF assist LEDs so that no red light reached the test target. Even so, the camera still back focuses, just like when the red light is on the target. This excludes the possibility that the problem has anything to do with the colour of the light. Something else must be wrong, not the colour.

I have even removed the red Plexiglas filter which is in front of the LEDs but all that did was that the red light became stronger, no improvement of the focus accuracy. It is not the red filter that gives colour to the light, which I was hoping for. The three LEDs under the huge lenses are red in their own. It is also not the filter that produces the AF assist light pattern, even that is produced under those lenses.

Fast lenses become completely useless, creating totally out of focus images in 100% of the cases. This is totally unacceptable. With the 50/1.4G set to f/1.4, as in the image to the left, the focus is so out of target that one might easily suspect user error and camera movement, but no, that is not the problem at all. All the 50 images were equally out of focus when the AF assist light was on, and in focus when I turned it off in the flash menu. Imagine if the image on the left would represent a portrait and the eye lashes would be where the AF target circle is... The ears of the model would be in perfect focus but not the eyes. Who would pay for such image? 

Disabling the AF assist LED light in the flash and enabling the in-camera white AF assist LED resulted in perfect accuracy, as the image to the right shows, which is taken with the 24-120/G lens at f/4, consistently the same for all the images. Disabling even the in-camera white LED gave the same consistent accurate results, so the problem is gone as soon as the AF assist light of the flash is set to OFF.
Everything is of course repeatable and the focus error is consistently wrong, always the same direction (back focus) and always the same amount.

With the 50/1.4G the error was obviously the worst and most disturbing, since at f/1.4 the depth of field is considerably narrower than the other lenses, so back focus becomes a really serious problem with this lens, rendering the lens useless if the AF assist light of the SB-900 is activated. Never the less, if the AF assist light is disabled, as in the image to the left, even the 50/1.4 is very good, even at f/1.4 producing accurately focused images.


The AF assist light of the SB-900 is totally useless with the D800 and should be switched off until this error is fixed by Nikon. I suspect this is the case even with other flashes, not just the SB-900.

This is a very serious problem and it needs to be fixed ASAP. Regardless if the D800 AF module is very sensitive and in many situation the AF assist light is not necessary at all, but there are situations when it becomes necessary to use it and in any case, it should not make the camera worse.

This problem makes the D800 considerably less usable for professional work, since many type of work demands the use of AF assist light since the ambient light is often too low. 

Nikon must fix this as soon as possible

I don't know what causes the problem, but it is definitely not the colour of the light, since covering the LEDs does not change anything, the camera still back focus when the AF assist light is turned on.

Can it be the pattern? Possible, but not likely. The SB-900 AF assist light projects a pattern and unfortunately that pattern is projected even if the red filter is removed. On the other hand, the in-camera LED is not only white, but also not projecting any pattern, just a light beam. However, if the AF assist LEDs are completely covered and all the light from it is prevented from reaching the AF target then there is no pattern on the target yet there is still the same back focus problem when the AF assist light is turned on.

Can there be a problem with the new AF module? That is possible too, but as far as I know, the D4 uses the same AF module and in that case there should be a problem with that camera also.

The AF accuracy problem does not seem to be connected to the light at all, it seems as the problem is connected to the fact that the external flash AF assist LED is turned on, not necessarily providing light on the AF target since the problem is there even if the light is blocked by a thick cardboard sheet. Also, when the ambient light in the room is strong enough so that the AF assist LED never comes on due to the decision the camera makes, the camera again focuses with high accuracy without any problems. So it seems that the only criteria for the back focus is that a flash with external AF assist light is on the camera and that the camera forces the light to be used.

This problem should be brought to Nikon's attention in hope that they will fix this somehow. Some people say that this issue has a connection to the last firmware update, in which case it should be easy to fix. I don't know how to reverse the firmware to the previous release, my camera has the latest firmware and I cannot find any documentation on how to reverse an update.

Hopefully Nikon solves this soon. Contact Nikon and make them aware of this problem. Use the following link, or contact them in your own country.